Username: manager
Password: friend
awplus> ==> User Exec Mode
awplus> enable ==> To revert to User Exec mode type “disable”
awplus# ==> Privileged Exec Mode
awplus# configure terminal
awplus(config)# ==> Global Config Mode
awplus(config)# do show ip interface brief ==> add do if in Global Configuration mode
awplus> enable ==> To revert to User Exec mode type “disable”
awplus# ==> Privileged Exec Mode
awplus# configure terminal
awplus(config)# ==> Global Config Mode
awplus(config)# do show ip interface brief ==> add do if in Global Configuration mode
awplus(config)# hostname training ==> change
switch hostname
training(config)#
Port
configuration:
awplus# show interface brief ==> To show interface
awplus(config)# interface port1.0.1 ==> To configure a single interface
awplus(config-if)#
awplus(config)# interface port1.0.1-1.0.5, port1.0.10-1.0.12 ==> To configure a range of interfaces
awplus(config-if)#
awplus# configure terminal
awplus(config)# interface port1.0.2
awplus(config-if)# duplex (auto | full | half) ==> To change speed and duplex mode of a switch port
awplus(config-if)# speed (10 | 100 | 1000 | auto)
awplus(config)# vlan database
awplus(config-vlan)# vlan 2 ==> add vlan
awplus(config-vlan)# no vlan 2 ==> delete vlan
awplus# show ? ==> command help
Disabling switch ports:
awplus# configure terminal
awplus(config)# interface port1.0.20
awplus(config-if)# shutdown
Enabling switch ports:
awplus# configure terminal
awplus(config)# interface port1.0.20
awplus(config-if)# no shutdown
Save configurations:
awplus# show running-configuration ==> Display volatile parameters
awplus# copy running-config <filename.cfg> ==> To save the configuration from volatile memory to a flash memory
awplus# config term
awplus(config)# boot config <filename.cfg> ==> To set configuration file to current boot config
awplus# show boot
Boot configuration
awplus# show interface brief ==> To show interface
awplus(config)# interface port1.0.1 ==> To configure a single interface
awplus(config-if)#
awplus(config)# interface port1.0.1-1.0.5, port1.0.10-1.0.12 ==> To configure a range of interfaces
awplus(config-if)#
awplus# configure terminal
awplus(config)# interface port1.0.2
awplus(config-if)# duplex (auto | full | half) ==> To change speed and duplex mode of a switch port
awplus(config-if)# speed (10 | 100 | 1000 | auto)
awplus(config)# vlan database
awplus(config-vlan)# vlan 2 ==> add vlan
awplus(config-vlan)# no vlan 2 ==> delete vlan
awplus# show ? ==> command help
Disabling switch ports:
awplus# configure terminal
awplus(config)# interface port1.0.20
awplus(config-if)# shutdown
Enabling switch ports:
awplus# configure terminal
awplus(config)# interface port1.0.20
awplus(config-if)# no shutdown
Save configurations:
awplus# show running-configuration ==> Display volatile parameters
awplus# copy running-config <filename.cfg> ==> To save the configuration from volatile memory to a flash memory
awplus# config term
awplus(config)# boot config <filename.cfg> ==> To set configuration file to current boot config
awplus# show boot
Boot configuration
--------------------------------------------
Current software : r1-5.2.1-0.4.rel
Current boot image : flash:/r1-5.2.1-0.4.rel
Backup boot image : flash:/r1-5.2.1-0.2.rel
Default boot config: flash:/default.cfg
Current
boot config: flash:/filename.cfg (file exists)
Or
awplus# write memory or wr mem
awplus# copy running-config startup-config
File and management:
awplus# dir
awplus# show file sys
Or
awplus# write memory or wr mem
awplus# copy running-config startup-config
File and management:
awplus# dir
awplus# show file sys
awplus# reload
==> Reboot switch
awplus> show system ==> Get system general information
awplus> show system ==> Get system general information
Add
& delete users:
awplus(config)# username test privilege 15 password test ==> Add a new user
awplus(config)# no username test ==> Delete a user
awplus(config)# username test privilege 15 password test ==> Add a new user
awplus(config)# no username test ==> Delete a user
The AlliedWare Plus
OS provides 15 privilege levels, divided into 3 groups:
Levels 1-6: provide access to most show commands, in User Exec mode
Levels 7-14: provide access to some more show commands, in Privileged Exec mode
Level 15: provides access to some additional show commands and all configuration commands, in Privileged Exec mode
Date and Time:
awplus# show clock ==> Display current date and time
awplus# clock set <hh:mm:ss> <day> <month> <year> ==> Set date and time manually
awplus# clock set 12:00:00 01 sep 2019 ==> example
NTP to set date and time:
awplus# config terminal
awplus(config)# ntp peer 192.168.30.254 ==> Set NTP server
awplus(config)# clock timezone utc plus 2 ==> Set Time Zone
awplus# show ntp status
Firmware upgrade:
Download Firmware from www.alliedtelesis.com -> support -> software -> Access Restricted Software
Create Account for Login
Open TFTP Server Application
awplus# copy tftp://50.1.1.1/r1-5.3.2-0.1.rel flash: ==> To Copy From PC to Switch
awplus# dir ==> To Check Firmware in Switch
awplus(config)# boot system r1-5.3.2-0.1.rel ==> Upgrade Firmware
awplus# reload
Setting a Backup Image:
awplus# copy SBx908-5.4.2-2.5.rel SBx908-5.4.2-2.5.back.rel
awplus# configure terminal
awplus(config)# boot system backup SBx908-5.4.2-2.5.back.rel
awplus(config)# do show boot
Restore default configuration:
awplus(config)# no boot config-file ==> Reset to Factory Default if default.cfg has not been modified
awplus# delete force default.cfg ==> If the default.cfg has been modified
awplus# reload ==> Restart the switch
Or type <Ctrl+B> at boot time and use menu item 5. Special boot options, Skip startup script.
Password Recovery:
1) Press <Ctrl + B> at boot time for Boot Menu
2) Choose Option 5 – Special Boot Options
Boot Menu:
Levels 1-6: provide access to most show commands, in User Exec mode
Levels 7-14: provide access to some more show commands, in Privileged Exec mode
Level 15: provides access to some additional show commands and all configuration commands, in Privileged Exec mode
Date and Time:
awplus# show clock ==> Display current date and time
awplus# clock set <hh:mm:ss> <day> <month> <year> ==> Set date and time manually
awplus# clock set 12:00:00 01 sep 2019 ==> example
NTP to set date and time:
awplus# config terminal
awplus(config)# ntp peer 192.168.30.254 ==> Set NTP server
awplus(config)# clock timezone utc plus 2 ==> Set Time Zone
awplus# show ntp status
Firmware upgrade:
Download Firmware from www.alliedtelesis.com -> support -> software -> Access Restricted Software
Create Account for Login
Open TFTP Server Application
awplus# copy tftp://50.1.1.1/r1-5.3.2-0.1.rel flash: ==> To Copy From PC to Switch
awplus# dir ==> To Check Firmware in Switch
awplus(config)# boot system r1-5.3.2-0.1.rel ==> Upgrade Firmware
awplus# reload
Setting a Backup Image:
awplus# copy SBx908-5.4.2-2.5.rel SBx908-5.4.2-2.5.back.rel
awplus# configure terminal
awplus(config)# boot system backup SBx908-5.4.2-2.5.back.rel
awplus(config)# do show boot
Restore default configuration:
awplus(config)# no boot config-file ==> Reset to Factory Default if default.cfg has not been modified
awplus# delete force default.cfg ==> If the default.cfg has been modified
awplus# reload ==> Restart the switch
Or type <Ctrl+B> at boot time and use menu item 5. Special boot options, Skip startup script.
Password Recovery:
1) Press <Ctrl + B> at boot time for Boot Menu
2) Choose Option 5 – Special Boot Options
Boot Menu:
------------------------------------------------------
B. Boot backup software
------------------------------------------------------
0. Restart
1. Perform one-off boot from alternate
source
2. Change the default boot source (for
advanced users)
3. Update Bootloader
4. Adjust the console baud rate
5. Special boot options
6. System information
7. Restore Bootloader factory settings
------------------------------------------------------
9. Quit and continue booting
3) Choose option 1 to skip startup script
0. Return to previous menu
------------------------------------------------------
1. Skip startup script (Use system defaults)
Enter selection ==>
4) Switch will load default.cfg config and login using username: manager, password: friend
5) Edit startup config using “edit <filename.cfg>
6) Find the username and password line and delete the current password and type new password. Exit, Save and Reload Switch.
DHCP Server:
awplus(config)# service dhcp-server
3) Choose option 1 to skip startup script
0. Return to previous menu
------------------------------------------------------
1. Skip startup script (Use system defaults)
Enter selection ==>
4) Switch will load default.cfg config and login using username: manager, password: friend
5) Edit startup config using “edit <filename.cfg>
6) Find the username and password line and delete the current password and type new password. Exit, Save and Reload Switch.
DHCP Server:
awplus(config)# service dhcp-server
awplus(config)# ip dhcp
pool <name>
awplus(config)# network
<network-ip/Subnet-mask>
awplus(dhcp-config)#
range <ip-address> <ip-address>
awplus(dhcp-config)#
default-router <ip-address>
Types of Ports:
Untagged ports (Access Port) ==> Only one VLAN
Tagged ports (Trunk port) ==> Carry multiple VLANs
VLAN Configuration:
awplus# configure terminal
awplus(config)# vlan database
awplus(config-vlan)# vlan 3 ==> Create new VLAN 3
awplus(config-vlan)# vlan 4-6 ==> Create new VLAN 4 to 6
awplus(config-vlan)# no vlan 5 ==> Remove VLAN 5
awplus(config-vlan)# exit
Labs:
awplus(config)# vlan database
awplus(config-vlan)# vlan 104,200 ==> Create new VLAN 104 and 200
Labs2:
awplus(config)# vlan database
awplus(config-vlan)# vlan 101-115 ==> Create new VLAN 101 to 115
awplus(config)# interface vlan1
Types of Ports:
Untagged ports (Access Port) ==> Only one VLAN
Tagged ports (Trunk port) ==> Carry multiple VLANs
VLAN Configuration:
awplus# configure terminal
awplus(config)# vlan database
awplus(config-vlan)# vlan 3 ==> Create new VLAN 3
awplus(config-vlan)# vlan 4-6 ==> Create new VLAN 4 to 6
awplus(config-vlan)# no vlan 5 ==> Remove VLAN 5
awplus(config-vlan)# exit
Labs:
awplus(config)# vlan database
awplus(config-vlan)# vlan 104,200 ==> Create new VLAN 104 and 200
Labs2:
awplus(config)# vlan database
awplus(config-vlan)# vlan 101-115 ==> Create new VLAN 101 to 115
awplus(config)# interface vlan1
awplus(config-if)#ip
address 192.168.1.4/24 ==> VLAN 1 as Management VLAN with IP
awplus(config)# ip route 0.0.0.0/0 192.168.1.1 ==> This is Core Switch IP
Add & delete Access Ports (End Device Connectivity):
awplus# configure terminal
awplus(config)# interface port1.0.2
awplus(config-if)# switchport access vlan 2 ==> To add Access port(s) to a VLAN
awplus(config-vlan)# exit
awplus(config)# interface port1.0.2
awplus(config-if)# no switchport access vlan ==> To delete Access port(s)
Labs:
awplus(config)# interface port1.0.11
awplus(config)# ip route 0.0.0.0/0 192.168.1.1 ==> This is Core Switch IP
Add & delete Access Ports (End Device Connectivity):
awplus# configure terminal
awplus(config)# interface port1.0.2
awplus(config-if)# switchport access vlan 2 ==> To add Access port(s) to a VLAN
awplus(config-vlan)# exit
awplus(config)# interface port1.0.2
awplus(config-if)# no switchport access vlan ==> To delete Access port(s)
Labs:
awplus(config)# interface port1.0.11
awplus(config-if)#
switchport access vlan 104
awplus(config)#
interface port1.0.12
awplus(config-if)#
switchport access vlan 200
Add & delete Trunk Ports (Switch to Switch Uplink Connectivity):
awplus# configure terminal
awplus(config)# interface port1.0.1
awplus(config-if)# switchport mode trunk
awplus(config-if)# switchport trunk allowed vlan add 2,3 ==> To setup port1.0.1 with VLAN 2 & 3 tagged
awplus(config-if)# switchport trunk allowed vlan remove 2 ==> To remove a tagged VLAN from trunk port
Labs:
awplus(config)# interface port1.0.1-1.0.2
Add & delete Trunk Ports (Switch to Switch Uplink Connectivity):
awplus# configure terminal
awplus(config)# interface port1.0.1
awplus(config-if)# switchport mode trunk
awplus(config-if)# switchport trunk allowed vlan add 2,3 ==> To setup port1.0.1 with VLAN 2 & 3 tagged
awplus(config-if)# switchport trunk allowed vlan remove 2 ==> To remove a tagged VLAN from trunk port
Labs:
awplus(config)# interface port1.0.1-1.0.2
awplus(config-if)#
switchport mode trunk
awplus(config-if)# switchport trunk allowed vlan add 104,200 ==> To setup port1.0.1 and 1.0.2 with VLAN 104 & 200 tagged
Labs2:
awplus(config)# interface port1.0.1-1.0.2
awplus(config-if)# switchport trunk allowed vlan add 104,200 ==> To setup port1.0.1 and 1.0.2 with VLAN 104 & 200 tagged
Labs2:
awplus(config)# interface port1.0.1-1.0.2
awplus(config-if)#
switchport mode trunk
awplus(config-if)#
switchport trunk allowed vlan add 101-115
==> To setup port1.0.1 and 1.0.2 with
VLAN 101 to 115 tagged
awplus# configure
terminal
awplus(config)#
interface vlan101 ==> Routing Configuration on Core Switch
awplus(config-vlan)# ip
add 192.168.101.254/24
awplus(config)#
interface vlan102
awplus(config-vlan)# ip
add 192.168.102.254/24
awplus(config)#
interface vlan103
awplus(config-vlan)# ip
add 192.168.103.254/24
awplus(config)#
interface vlan104
awplus(config-vlan)# ip
add 192.168.104.254/24
awplus# configure
terminal
awplus(config)# service
dhcp-server ==> Configuring
DHCP Server on Core Switch
awplus(config)# ip dhcp
pool vlan101
awplus(dhcp-config)#
network 192.168.101.0/24
awplus(dhcp-config)#
range 192.168.101.10 192.168.101.100
awplus(dhcp-config)#
default-router 192.168.101.254
awplus(config)# ip dhcp
pool vlan102
awplus(dhcp-config)#
network 192.168.102.0/24
awplus(dhcp-config)#
range 192.168.102.10 192.168.102.100
awplus(dhcp-config)#
default-router 192.168.102.254
awplus(config)# service
dhcp-server
awplus(config)# ip dhcp
pool vlan103
awplus(dhcp-config)#
network 192.168.103.0/24
awplus(dhcp-config)#
range 192.168.103.10 192.168.103.100
awplus(dhcp-config)#
default-router 192.168.103.254
awplus(config)# ip dhcp
pool vlan104
awplus(dhcp-config)#
network 192.168.104.0/24
awplus(dhcp-config)#
range 192.168.104.10 192.168.104.100
awplus(dhcp-config)#
default-router 192.168.104.254
Show Trunk and Access VLANs:
awplus# show vlan all
Show Trunk and Access VLANs:
awplus# show vlan all
Virtual Chassis
Stacking
Default VLAN tag ID is 4094 & IP is 192.168.255.0 / 28
show stack
Default VLAN tag ID is 4094 & IP is 192.168.255.0 / 28
show stack
show stack detail
awplus# reload ==> Rebooting the stack
awplus# reload stack-member 2 ==> Just a specific member
awplus(config)# stack <member‟s existing ID> renumber <member‟s new ID> ==> Changing Stack Numbering
awplus(config)# stack <1-8> priority <0-255> ==> Changing Stack Priority, Lowest Priority Value has higher priority.
awplus(config)# stack resiliencylink <interface> ==> Setting Stack Resiliency Link
awplus(config)# stack virtual-mac ==> Configuring Stack Virtual MAC
Link Aggregation
awplus# config terminal
awplus(config)#
interface port1.0.3-1.0.4
awplus(config-if)#
static-channel-group 2 ==> Creating a static channel group. NOTE: The port
properties within the group must match e.g. VLAN, speed & duplex
awplus# show
static-channel-group ==> Display all static channel groups
% Static Aggregator: sa2
% Member:
port1.0.3
port1.0.4
awplus# show diagnostic
channel-group
awplus(config)# interface port1.0.4
awplus(config)# interface port1.0.4
awplus(config-if)# no
static-channel-group ==> Delete a port from group. Note: this will also delete
the static channel group after the last member is deleted
awplus(config)# interface port1.0.3,port1.0.5
awplus(config)# interface port1.0.3,port1.0.5
awplus(config-if)#
channel-group 2 mode active ==> Creating a LACP channel group. Note: Port is either
active or passive (i.e. waiting for active partner)
awplus# show etherchannel ==> Display the LACP groups
awplus# show etherchannel ==> Display the LACP groups
% Lacp Aggregator: po2
% Member:
port1.0.3
port1.0.5
awplus# show diagnostic channel-group
Labs3:
In Core Switch:
awplus(config)# vlan database
awplus# show diagnostic channel-group
Labs3:
In Core Switch:
awplus(config)# vlan database
awplus(config-vlan)#
vlan 10
awplus(config)#
interface port1.0.1,port2.0.1
awplus(config-if)#
static-channel-group 1 ==> Creating a static channel group in core switch
awplus(config)#
interface port1.0.4,port2.0.4
awplus(config-if)#
channel-group 1 mode active ==> Creating a LACP channel group in core switch
awplus(config)#
interface port1.0.5,port2.0.5
awplus(config-if)#
channel-group 2 mode active
awplus(config)# interface port1.0.11,port2.0.11
awplus(config)# interface port1.0.11,port2.0.11
awplus(config-if)#
switchport access vlan 10
awplus(config)# interface sa1 ==> Configure static channel group. If more sa, interface sa1-3
awplus(config-if)# switchport mode trunk
awplus(config-if)# switchport trunk allowed vlan add 10
awplus(config)# interface po1-2 ==> Configure LACP channel group
awplus(config-if)# switchport mode trunk
awplus(config-if)# switchport trunk allowed vlan add 10
awplus(config)# interface vlan10
awplus(config-if)# ip address 192.168.1.254/24
awplus(config)# stack virtual-mac ==> Configure Stack Virtual MAC
In switch that configure static channel group:
awplus(config)# vlan database
awplus(config)# interface sa1 ==> Configure static channel group. If more sa, interface sa1-3
awplus(config-if)# switchport mode trunk
awplus(config-if)# switchport trunk allowed vlan add 10
awplus(config)# interface po1-2 ==> Configure LACP channel group
awplus(config-if)# switchport mode trunk
awplus(config-if)# switchport trunk allowed vlan add 10
awplus(config)# interface vlan10
awplus(config-if)# ip address 192.168.1.254/24
awplus(config)# stack virtual-mac ==> Configure Stack Virtual MAC
In switch that configure static channel group:
awplus(config)# vlan database
awplus(config-vlan)#
vlan 10
awplus(config)# Interface port1.0.1-1.0.2
awplus(config)# Interface port1.0.1-1.0.2
awplus(config-if)#
static-channel-group 1 ==> Creating a static channel group
awplus(config)#
interface port1.0.11
awplus(config-if)#
switchport access vlan 10
awplus(config)# interface sa1 ==> Configure static channel group.
awplus(config)# interface sa1 ==> Configure static channel group.
awplus(config-if)#
switchport mode trunk
awplus(config-if)#
switchport trunk allowed vlan add 10
awplus(config)# interface vlan10
awplus(config)# interface vlan10
awplus(config-if)# ip
address 192.168.1.1/24
In switch that configure LACP channel group:
awplus(config)# vlan database
In switch that configure LACP channel group:
awplus(config)# vlan database
awplus(config-vlan)#
vlan 10
awplus(config)#
interface port1.0.1-1.0.2
awplus(config-if)#
channel-group 1 mode active ==> Creating a LACP channel group
awplus(config)#
interface port1.0.11
awplus(config-if)#
switchport access vlan 10
awplus(config)#
interface po1 ==> Configure LACP channel group
awplus(config-if)#
switchport mode trunk
awplus(config-if)#
switchport trunk allowed vlan add 10
awplus(config)#
interface vlan10
awplus(config-if)# ip
address 192.168.1.4/24
Ethernet Protected Switch Ring (EPSRing):
show epsr
Ethernet Protected Switch Ring (EPSRing):
show epsr
Labs4:
In Switch that configure EPSRing Master - (Switch 1)
awplus(config)# vlan database
awplus(config-vlan)#
vlan 100 name data-vlan ==> Create Data VLAN and Control VLAN
awplus(config-vlan)#
vlan 500 name control-vlan
awplus(config)# interface port1.0.5-1.0.12
awplus(config)# interface port1.0.5-1.0.12
awplus(config-if)#
switchport access vlan 100 ==> Assign Access Port for Data VLAN
awplus(config)# interface port1.0.1-1.0.2
awplus(config)# interface port1.0.1-1.0.2
awplus(config-if)#
switchport mode trunk ==> Assign Trunk Port for EPSR
awplus(config-if)#
switchport trunk allowed vlan add 100,500
awplus(config-if)#
switchport trunk native vlan none
awplus(config)# interface vlan100
awplus(config)# interface vlan100
awplus(config-if)# ip
address 192.168.1.1/24 ==> Assign Management IP for Switch
awplus(config)# epsr configuration ==> EPSR Ring Configuration
awplus(config)# epsr configuration ==> EPSR Ring Configuration
awplus(config-epsr)#
epsr training mode transit controlvlan 500
awplus(config-epsr)#
epsr training datavlan 100
awplus(config-epsr)#
epsr training state enabled
Collecting switch information:
awplus# sho log ==> Displaying Logging Entries in Buffered Log
Collecting switch information:
awplus# sho log ==> Displaying Logging Entries in Buffered Log
awplus# sho log permanent ==> Displaying Contents of Permanent Log
Logging Levels:
Remote syslog server:
awplus# configure terminal
awplus(config)# log host
192.168.30.33 level 5 ==> Dumps log entries to a remote syslog server.
SMTP server:
awplus(config)# mail smtpserver 192.168.30.12 ==> Update SMTP server
SMTP server:
awplus(config)# mail smtpserver 192.168.30.12 ==> Update SMTP server
awplus(config)# mail
from training@atmy.my
awplus(config)# log email ali.baba@atmy.my level 5 ==> Configure email logging
awplus# show system environment
awplus(config)# log email ali.baba@atmy.my level 5 ==> Configure email logging
awplus# show system environment
awplus# show system serialnumber ==> Show the serial number
awplus# show system pluggable [<port-list>] ==> Show pluggable SFPs, XFPs
awplus# show cpu
awplus# show interface status
Collecting information:
awplus#show tech-support ==> Run “show tech-support” before rebooting
Copying files from the switch:
awplus# dir awplus-3/flash:/ ==> To list files on a backup member
awplus# copy awplus-3/flash:/<filename> flash ==> To copy a file from a backup member, it must be copied to the master‟s flash first, as files can not be copied directly from backup members to external locations.
Backup to USB drive:
awplus#copy default.cfg usb:
awplus#copy usb:/default.cfg f.